Sui Mainnet Network
Incident Report for
Sui
Resolved
This incident has been resolved.
Posted
Dec
14
,
2025
-
15:03
PST
Investigating
We are currently investigating degraded consensus, much higher latencies.
Posted
Dec
14
,
2025
-
11:52
PST
This incident affected: Sui Mainnet - Validators and Sui Mainnet - Public RPC Nodes.
×
Subscribe to Incident
Subscribe to updates for
Sui Mainnet Network
via . You'll receive .